10.24.2025 Assessment Analytics Data Lag

Incident Report for Otus Status Page

Resolved

Assessment Analytics is now back to real time. Appreciate your patience.
Posted Oct 24, 2025 - 16:01 CDT

Monitoring

Our team has identified the root cause of an issue delaying our assessment analytics successfully implemented a fix.

Users will continue to experience delays in Assessment Analytics as our system processes and catches up. We anticipate being back to real-time by the end of the day.

We will continue to monitor the system's progress throughout this process.

We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve this. Thank you for your understanding!
Posted Oct 24, 2025 - 10:03 CDT
This incident affected: Analytics.